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In this module, we'll look at how X, the most graphical
user interface for Linux and UN*X in general, works,
and the various components involved. We'll find out
about window managers and desktop environments,
file managers, and how we do day-to-day management
tasks and just a bit of system administration from the
graphical desktop.

Historically, UNIX started with text terminals
connected to a central server machine. Later on,
people wanted to do graphics, and X Windows (or just
X) was developed to connect graphical terminals to
the server machine. X requires two pieces: an X
server and an X client. The X server machine (aka X
terminal) draws graphics on a display from commands
received over the network via TCP port 6000. The X
client runs the application, which sends X commands
to the X server. Nowadays, the X server and X client
usually run on the same computer, but not necessarily!

Here's a graphical representation of how it all works.
The client application talks to the TCP/IP software
stack, which sends commands to the server over the
network. The server machine receives those
commands and figures out how to draw the graphics
the client is asking for.
If the client and server are running on the same
machine, the TCP/IP software knows that it doesn't
have to put commands destined for “localhost” out on
the network wire; it processes them internally.

Basic UNIX 4:
More on the GUI

● How X works

● Window and desktop managers

● File managers

● Common tasks

● System administration tools

How X works

● X server (X)

– Provides tools for drawing graphics on a
display

– X applications send commands to the X
server via TCP/IP

● X client

– Machine running the software that wants
to draw graphics

– Usually the machine running the server,
but doesn't have to be!
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You might run applications remotely because:
The software vendor wants to handle licensing
by keeping the software on a single machine and
letting workstations display the output. SAS 9.1
is like that.
A small workstation (even diskless) can run
software too large for it by displaying output
from software run on another machine. The
Linux Terminal Server Project uses this idea to
get several workstations for the price of one: see
www.ltsp.org for more info.

X is normally insecure, and baddies can either
snoop on your X session or display bad stuff on
your machine. The “-X” option tells ssh to
create a secure network tunnel for the normally
insecure X protocol. Don't use “-x”; that's the
flag that tells ssh not to allow X tunneling.
[ Exercise:
1. Open a shell window.

2. At the shell prompt, type
ssh -X netid@sas.iastate.edu
where “netid” is your ISU NetID.

3. Once logged in, type
sas
to start the SAS program.

4. Close all the SAS windows and press
<Ctrl/D> to log out. ]

The window manager is the software responsible
for drawing and positioning windows and other
objects on the desktop and managing virtual
desktops (if they're available). It may also
handle creating menus, copy-and-paste and other
niceties.
KDE and the Gnome Desktop are very MS
Windows-like, mostly because MS Windows is
much like Motif, an earlier UNIX window
manager. However, the window manager can be
very much unlike Motif, as the following
examples show.

Why is this good?

● Applications are independent of
graphics hardware, window manager
and even hardware platform

● Server and client do not have to be on
the same machine; applications can be
run remotely

– Licensing considerations

– Horsepower restrictions

Running X applications
remotely

● Connect to a remote machine using ssh
with the -X option (not -x)

ssh -X netid@sas.iastate.edu
● Start the application

sas

Window managers
● Manages positioning of windows on the
screen, virtual desktops, running
applications; may include menus

– AfterStep

– Blackbox

– Enlightenment

– FVWM

– IceWM

– Sawfish

– etc., etc., etc., etc. TCP/IP Stack

X Server

Window Manager

Display Driver
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AfterStep 2.0, an easily configurable window
manager. WindowMaker, a good choice for smaller

machines (we'll see more of it later).
A desktop environment goes beyond window
management to include its own GUI system
utilities, standard applications and other goodies.
Microsoft Windows is really a desktop
environment. KDE and Gnome Desktop are the
most well-developed and popular desktop
environments for Linux.
[ Exercise: log in to the K Desktop Environment
and examine some of the choices in the
Accessories, Games, Graphics, Internet, Office
and “Sound & Video” menus. Bear in mind that
almost all of this software was installed from the
Red Hat CDs and is included at no extra charge. ]

If you're a system administrator, you'll have to
get used to the fact that, within the limits you set,
your users will have lots of choices of desktop
appearance and behavior. Not only can they
choose window manager, but they can choose
themes that can make one machine look
completely different from another maching
running the same window manager. Of course,
they can only do that if you allow them to install
the window manager and/or themes. Since you
have more control over that with Linux, you can
be more restrictive if you want to.

Desktop Environments

● Window management + system utilities
+ standard applications + games +
menuing system + ????????

– K Desktop Environment (KDE)

– GNOME Desktop

– Microsoft Windows

What you'll have to get used
to...

● Users have a choice of window/desktop
manager (even in the stock RedHat
install)

● Many desktop managers are themeable,
i.e., FVWM may look completely
different from FVWM on another
machine depending on the choice of
theme
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One reason for using a non-standard window
manager is that modern desktop environments
are resource hogs. Putting a smaller, lighter
window manager (say, IceWM) can give a whole
new lease on life to machines that you were
going to send to surplus.

And choices can make you more popular with
your users as well. If they can select their native
language and favorite window manager, that's a
lot more harmless way of customizing the
machine than installing insecure software from
who knows where. And the right window
manager/theme choice can let your (former)
Windows users have a familiar look and feel
without having to give them Windows.

FVWM with RedmondXP FVWM with Redmond98

Why choice is good...

● The window manager can be selected
based on the horsepower of the
machine

– Gnome, KDE run well on big, modern
hardware

– Blackbox, FVWM, IceWM, SWM, etc. run
better on older machines

Choice is good II

● International users can customize their
WM with non-English languages

● A choice of window manager/theme
gives users something harmless to
customize their environment with

● Windows users can have a Windows-like
DM (FVWM with RedmondXP or
Redmond98)
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There are several ways to select a window
manager. We've already seen how to choose one
from the Session menu, but you can also choose
a default by modifying .Xclients (for your own
default) or /etc/sysconfig/desktop (for a global
default – you'll have to be root to modify that
file).

In this class, I'm going to emphasize the K
Desktop Environment over some of the others.
Why? Because it's probably the best choice for
modern hardware. It's most popular, the system
tools are better, and Konqueror is more stable
than Gnome's Nautilus (especially when working
with OpenAFS).
The “Start Menu” in KDE is really called the K
Menu, but because Red Hat puts their red hat
icon on it instead of KDE's default K, we'll also
call it the Start Application menu. Sorry for the
confusion.

Most modern window managers believe in the
Windows <Alt/Tab> for switching windows, but
not all, so you may have to try clicking on the
window (or even the titlebar) if it doesn't work.

Switching Between Windows

● Varies; most modern WM accept the
Windows <Alt/Tab> and clicking on the
window

● Some window managers (like Blackbox
and TWM) insist that you click on the
window titlebar or use arrows on the
manager bar

Choosing a Window Manger

● On startup – choose from the “Session”
menu in the login screen

● Set a user default – insert
PREFERRED=”windowmanagerapp”
into ~/.Xclients

● Setting system default – put
DESKTOP=”KDE”
DESKTOP=”GNOME”
DESKTOP=”windowmanagerapp”

into /etc/sysconfig/desktop

Why KDE?

● Most popular desktop manager for
“large” systems

● One of the two desktop environments
installed by Red Hat Enterprise Linux

● Has most complete set of applets and
management tools

● Default file manager (Konqueror) works
better with AFS volumes than Nautilus
(Gnome)
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For creating documentation or just capturing
pictures it's useful to capture the graphic screen
to a file. There used to be an application in
RHEL to do that, but they left it out of the new
version. Here's how you do it with GIMP, which
does a better job anyway.
[ Exercise: save a copy of any window on your
screen.
1. Start GIMP from the Graphics menu.
2. Choose File > Acquire > Screen Shot
3. Click OK, then in the window you want to
save.

4. Save the picture with File > Save As. ]
[ Exercise:
1. Select System Settings -> Date and Time
2. Enter the root password
3. Verify that the location is somewhere in the
Central time zone

4. Turn on Enable Network Time Protocol and
select or enter “time.iastate.edu” as the server.

5. Click Apply. ]

[ Exercise:
1. Move the KDE Panel to the right side of the
screen.

2. Make the icons Small or Tiny rather than
Normal. ]

Capturing the Screen

● Used to be an application in the menu,
left out in new version

● Graphics > GIMP Image Editor

● Choose File > Acquire > Screen Shot

● Click OK

● Save the file as an appropriate graphics
type

Setting the Time
● Select System Settings -> Date and
Time

● Enter the root password

● Make sure that the time zone is set
correctly for your location

● If not Internet connected, turn off
“Enable Network Time Protocol” and
set time and date; otherwise, just select
a time server (time.iastate.edu works
fine)

Moving the KDE Panel

● Choose Preferences -> More
Preferences -> Configure Panel

● Click “Arrangement”

● Under Position, click where you'd like
the panel to appear.

● Under Size, choose the icon size you'd
like to use.

● Click Apply, then OK.
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When you install software, you'll probably want
to put it in the K Menu (aka Start Applications
menu – the theme Red Hat uses puts their Red
Hat logo in the Panel instead of the default K).
Some installers recognize the K Menu and do it
for you, but not all of them. And your users will
want to rearrange things anyway...

[ Exercise:
1. Start the Menu Editor. Right-click the Start
menu icon and choose “Menu Editor”.

2. Highlight “Accessories” and click “New
Item”.

3. For Item Name, enter “Gimp” and click
“OK”.

4. Under Command enter “gimp”.
5. Click the blank icon at the right and pick one
you like (there is one for Gimp).

6. Choose File > Save.
7. Verify that the item appears in the
Accessories menu, and that it works.

8. Close the Gimp windows. ]
[ Exercise:
1. Right-click on the Gimp item we just created
and select “Cut”.

2. Open the Graphics folder by clicking on the
plus sign to the left.

3. Right-click on “Office” and select “Paste”,
then choose File > Save.

4. Verify that Gimp now appears under “Office”.
]

Editing the K Menu

● Right-click on the Start Applications
icon

● Select “Menu Editor”

● You can:

– Add entries

– Remove entries

– Rearrange entries

Adding a Menu Entry

● Highlight the folder you want the item
to appear in

● Click “New Item”

● Enter the values for the program:

– Name

– Comment

– Command (with options if necessary)

● Select File > Save

Moving a Menu Entry

● Right-click on the item to be moved

● Select “Cut”

● Right-click on the folder you want it to
appear in

● Select “Paste”

● Select File > Save
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[ Exercise:
1. Open a Konqueror window by choosing
Home from the K Menu.

2. If you can't see the .kde folder, choose View
-> Show Hidden Files.

3. Double-click on .kde to open it, then double-
click on Autostart.

4. Open another Konqueror window.
5. Use the Up button to browse up to /, then
down to /usr/X11R6/bin.

6. Drag xclock from the /usr/X11R6/bin
window to the .kde/Autostart window.

7. Release the mouse button, then click
“Link Here”. ]

Many of the settings in the Control Center apply
only to the user running CC. (Those settings will
be stored in the .kde directory in your home
directory.) Bear in mind that if a window has an
“Administrator Mode” button in it, you will be
changing those settings for all users, not just you,
so you'll need the root password to do that.
[ Exercise:
Select “Control Center” from the K Menu (aka
Start Applications menu).
]

The Appearance and Themes section of Control
Center governs how the Desktop looks. The
Theme Manager allows a wide variation in
appearance even within KDE itself.
[ Exercises:
1. Choose a background wallpaper.
2. Examine the choices of screen saver (choose
one, then click “Test”); pick “Random” when
you're finished.

3. Examine the styles available; switch from the
Bluecurve style (the Red Hat default) to KDE
Default ]

Starting Apps Automatically
KDE-aware apps left open at logout will
automatically reopen at your next login.
For others:

● In Konqueror, open ~/.kde/AutoStart

● In another Konqueror window, browse
to the application you want to run at
startup

● Drag the icon of the app to the
AutoStart window

● Choose “Link Here”

KDE Control Center

● Used to make a wide variety of system
settings in KDE

● Select “Control Center” from the Start
Applications Menu

Appearance and Themes

● Background

● Screen Savers

● Styles

● Theme Manager
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[ Exercises:
1. Set the left mouse button to open the
application menu on desktop click. This is
the default in WindowMaker; turn it off again.

2. Set the number of virtual desktops to six, then
back to four.

3. Change the screen resolution to something
smaller. Allow it to revert to the standard
setting.

4. Show the options in the Window Behavior
menu. Under Moving, point out that slow
machines benefit from turning off “Display
content in...” ]

You can use KDE (and many other window
managers) without a mouse, but you have to turn
it on in the Control Center (choose Mouse >
Mouse Navigation > “Move pointer...”.
Just press <Shift/NumLock> and use the numeric
keypad keys to move the mouse pointer. The 5
key is the mouse button, modified by the slash,
star and minus keys to select which button is
clicked when you press it. To click and hold,
press keypad 0 to hold, then 0 again to release.

We'll do more with system administration later in
the sequence, often using the command line, but
some of those functions are available here in the
KDE Command Center.
Unfortunately, to add a font you need a TrueType
or PostScript Type 1 font file.
[ Exercises:
1. Look at the Font Installer tool.
2. Select the Login Manager and click
“Administrator Mode”. Enter the root
password. Choose “Sessions” and set Remote
shutdown to either “Nobody” or “Only
root”. ]

Desktop

● Behavior

– What mouse clicks do

– What devices appear on the desktop

– Show previews for files

● Multiple Desktops

● Size & Orientation

– Screen resolution

– Rotation where available

Mousing Without a Mouse

● Must turn on in Control Center under
Mouse

● Press <Shift/NumLock>

● Move mouse pointer with the numbers
around the numeric keypad

● Click mouse button with keypad 5

– / for left, * for middle, - for right, then 5
● Click-and-hold with keypad 0

● Press <Shift/NumLock> again to turn off

System Administration

● To actually make changes here, you'll
need the root password.

● Font Installer

● Login Manager

– Customize the login screen

– Sessions – control who can shut down
machine from the console or remotely
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[ Exercises:
1. Select Preferences -> About Myself. Change
the linuxed full name to “Linux Lab User”
and make the office number “89 Durham”.

2. Select Preferences -> Password. Change the
password from “linuxed” to “whynot?”. Then
change it back to “linuxed”. ]

Services are background programs that are
owned by the system, not by the user. They
provide things like printing, Internet services.
firewall, etc.

The Add/Remove Programs tool installs and
uninstalls programs specifically from the Red
Hat CDs. It's the same system that was used to
install packages during the system installation.
If the machine is connected to the Internet
through a fast network and is registered with the
Red Hat Network, you're better off using the
tools on the Web at http://rhn.redhat.com to add
and remove packages:
• Packages you install with RHN are registered
for automatic notification/installation of
updates;

• Awider variety of packages is available
through the non-RedHat (ISU) channels.

Preferences

● About Myself – stores personal
information (real name, phone number,
etc.)

● Password – sets new password
(including the Kerberos password, if
Kerberos is used for authentication)

System Settings
● Server Settings -> Services
Used to start, stop and control system
services

– See info about a service: highlight the
service name

– Start/stop a service: highlight the name,
click the start or stop buttons

– Schedule a service to start at machine
startup: turn on the check box to the left
of the service name

– Actually runs system-config-services

System Settings ->
Add/Remove Programs

● Used to install and remove programs
from the Red Hat CDs

● To install a package, click details, the
check box next to the package name,
click Close, then click Update.

● To remove a package, click Details,
clear the check box next to the package
name, click Close, then click Update.
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[ Exercise: log out and log back in using the
Gnome Desktop instead of KDE. Now choose
the Preferences menu to explore the settings
changes possible for the Gnome Desktop. ]

One of the good things about Gnome Desktop is
for those with various disabilities is that lots of
assistive technology is built in. Not only does
Gnome support special keyboard features for
those with motor control problems (like slow and
sticky keys), but for the visually impaired there
are screen magnifiers and even a full-blown
audio screenreader (which usually costs several
hundred dollars in that other operating system).
All of these features can be activated under
Preferences > Accessibility.

You can take screenshots with GIMP the way we
did in KDE, but Gnome also has its own little
screenshot utility. Unfortunately, it only dumps
the entire screen; you can't select part of the
display or an open window.
[ Exercise: Save the screen to a file.
1. Choose Actions > Take Screenshot.
2. Enter a filename.
3. Click Save. ]

Gnome Desktop Prefs

● Many Linux systems have both KDE and
Gnome installed, and KDE utilities can
be run from the Gnome Desktop (they
usually show up under “More
Preferences”)

● Most Gnome preferences are user-
oriented and don't require root access

Assistive Technology

● Gnome comes with assistive technology
built in

● Preferences > Accessibility >
Accessibility – enables special keyboard
features (slow/sticky/mouse keys)

● Preferences > Accessibility > Assistive
Technology Support – activate screen
magnifier, on-screen keyboard and
audio screenreader (Gnopernicus)

Screenshots with Gnome

● Easy to take shot of whole screen, but
can't select a window like GIMP can

● Choose Actions > Take Screenshot

● Enter and/or browse a filename

● Click Save
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WindowMaker is an alternative to KDE and
Gnome. It's especially good on older machines,
as the overhead is much smaller. If you don't
have WindowMaker on your RHEL machine and
you've set up for the Dag Wieers repository
(which is done automatically with the Iowa State
install) you can install it with the command

up2date -i windowmaker

Many features of WindowMaker are triggered by
right-clicking. Right-clicking the desktop
activates the application menu, which will stay
open until you select something. If you move
the menu by dragging its title bar, it will stay
open (and on top of the other windows) until you
click its close box. You can do the same thing
with submenus as well, and the parent menu can
be closed without closing the submenu.

The Dock, in the upper right-hand corner, has
icons to launch commonly used applications. If
three dots appear on the button, the application
can be launched. If not, the application is
already running.
There are also “dockapps”, applications designed
specifically to run in the dock for chores like
displaying weather, mounting CDs, etc.

WindowMaker

● Window manager (not a desktop
environment)

– Lower overhead, good choice for smaller
machines

– No applets to clutter screen, take up CPU
time

● Part of GNUStep project, derived from
OpenStep, derived from NeXTStep
(which also was the origin of Mac OS X)

Where's the Start Menu?

● Everywhere! Just
right-click on the
Desktop.

● Move the menu to
make it stick

● Sub-menus can be
dragged off the menu
to stick independently

The Dock

● Double-click on icon to launch
app (if 3 dots appear)

● To add icons, open an app and
drag its icon to the Dock, then
enter the command to start it

● Drag icon out of Dock to remove

● “Screwdriver” icon starts the
WindowMaker Preferences tool

● Many dockapps are available
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The WindowMaker title bar is simpler than the
others; you minimize on the left and close on the
right. Double-clicking on the titlebar reduces the
window to the titlebar (windowshading). For
anything fancier than that, right-click on the
titlebar for the window menu.
Moving a window is done by dragging the
titlebar, and resizing the window is done by
click-hold-and-drag on the lower corners of the
window (betraying WM's Mac OS heritage).

WindowMaker has a unique trick; it can create
new virtual workspaces on the fly. Just choose
“Workspaces > New” from the Application
menu. To move windows, right-click on the
titlebar and choose “Move to”. To switch
workspaces, click on the arrows on the Clip or
choose a workspace from the Application menu.
Notice that workspaces can be named; right-click
on the Clip to rename the workspace.

[ Exercise:
1. Log out of WindowMaker and log back in
using Failsafe.

2. Type ooffice at the command prompt to prove
you're really running a window manager (just
not a very good one).

3. Exit OpenOffice.org, then press <Ctrl/D> to
return to the login screen. ]

Last Revised September 20, 2005 by Jeff Balvanz (jbalvanz@iastate.edu)

The Failsafe WM

● Failsafe is an extremely primitive
window manager

● You may find yourself in Failsafe when
KDE and/or Gnome get corrupted
somehow

● To exit Failsafe, press <Ctrl/D> in the
terminal window.

Handling Windows

● Left title-bar button
minimizes (double-click
icon below to restore)

● Right title-bar button
closes

● Double-click title bar to
windowshade

● Right-click-and-hold title
bar to get window menu

Workspaces in WindowMaker
● Only two workspaces at startup,
create new workspaces as
necessary

● From Application menu, choose
Workspaces -> New

● Use the Application menu or
arrows on the Clip to switch
workspaces

● To remove a workspace, empty it,
leave it and choose Workspaces >
Destroy Last


